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Conventions Used in this Guide
Please take a moment to review how instructions and other 
useful information are presented in this guide. 
•    The project tree is the main project area of the Project Man-

ager window. These two terms (project tree and Project 
Manager window) may be used interchangeably in this 
guide.

•    Procedures are presented as numbered lists. A single bullet 
indicates that the procedure has only one step.

•    Bold type is used for the following:

- Keyboard entries that should be typed in their entirety 
exactly as shown. For example, “copy file1” means to 
type the word copy, to type a space, and then to type 
file1.

- On-screen prompts and messages, names of options and 
text boxes, and menu commands. Menu commands are 
often separated by carats. For example, click Max-
well>Excitations>Assign>Voltage.

- Labeled keys on the computer keyboard. For example, 
“Press Enter” means to press the key labeled Enter.

•    Menu commands are often separated by the “>” symbol. 
For example, “Click File>Exit”.

•    Italic type is used for the following:

- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be 
typed in place of the words in italics. For example, 
“copy file name” means to type the word copy, to type a 
space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indicate 
that you should press the keys at the same time. For exam-
ple, “Press Shift+F1” means to press the Shift key and the 
F1 key at the same time.

•    Toolbar buttons serve as shortcuts for executing com-
mands. Toolbar buttons are displayed after the command 
they execute. For example,
 i
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“Click Draw>Line ” means that you can also click the 
Draw Line toolbar button to execute the Line command.
 ii 
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Getting Help

Ansoft Technical Support
To contact the Ansoft technical support staff in your geographi-
cal area, please go to the Ansoft website, http://
www.ansoft.com, click the Contact button, and then click Sup-
port. Phone numbers and e-mail addresses are listed for the 
technical support staff. You can also contact your Ansoft 
account manager to obtain this information.
All Ansoft software files are ASCII text and can be sent conve-
niently by e-mail. When reporting difficulties, it is helpful to 
include specific information about what steps were taken or 
what stages the simulation reached. This promotes more rapid 
and effective debugging.

Context-Sensitive Help
To access online help from the Maxwell user interface, do one 
of the following:
•    To open a help topic about a specific Maxwell menu com-

mand, press Shift+F1, and then click the command or tool-
bar icon.

•    To open a help topic about a specific Maxwell dialog box, 
open the dialog box, and then press F1.
 iii
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1 Introduction
This Getting Started Guide is written for Maxwell begin-
ners and experienced users who would like to quickly re-
familiarize themselves with the capabilities of Maxwell. 
This guide leads you step-by-step through creating, solv-
ing, and analyzing the results of solving a rotational actua-
tor magnetostatic problem.
By following the steps in this guide, you will learn how to 
perform the following tasks:
 Draw a geometric model.
 Modify a model’s design parameters.
 Assign variables to a model’s design parameters.
 Specify solution settings for a design.
 Validate a design’s setup. 
 Run a Maxwell simulation.
 Plot the magnetic flux density vector.
 Run a parametric analysis.
 Create an animation using saved parametric field data.

Estimated time to 
complete this guide:
60minutes.
Introduction 1-1
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Maxwell Solution Types
Maxwell® is an interactive software package that uses finite 
element analysis (FEA) to simulate (solve) electromagnetic 
field problems. Maxwell integrates with other Ansoft software 
packages to perform complex tasks while remaining simple to 
use. Maxwell® incorporates both a set of 2D solvers and 3D 
solvers in an integrated user interface. This guide will focus 
on 3D capabilities. 2D problems examples are cover in sepa-
rate 2D Getting Started Guides.

The following six types of stand-alone solutions are supported 
by Maxwell 3D:

• Magnetostatic linear and nonlinear 3D fields caused by 
a user-specified distribution of DC current density and permanent 
or externally applied magnetic fields. Materials can be non-linear 
and anisotropic. Additional quantities that can be computed include 
torque, force, and self and mutual inductances.

• Harmonic (sinusoidal variation in time) steady-state 
magnetic fields with pulsation-induced eddy currents in mas-
sive solid conductors caused by one of the following:
a. A user-specified distribution of AC currents (all with the same 

frequency but with possibly different initial phase angles).
b. Externally applied magnetic fields. 
This solution includes displacement currents for calculating near 
field electromagnetic wave radiation.

• Transient (time domain) magnetic fields caused by per-
manent magnets, conductors, and windings supplied by voltage 
and/or current sources with arbitrary variation as functions of time. 
Rotational or translational motion effects can be included in the 
simulation.

• Electrostatic 3D fields caused by a user-specified distribution 
of voltages and charges in non-conducting regions. Additional 
quantities that can be computed include torque, force, and capaci-
tances.

• Electric DC Conduction 3D fields in conductors character-
ized by a spatial distribution of voltage, electric field, and current 
density. Power loss can also be computed. In addition, optional 
simulation of fields in insulating materials is supported.

• Transient (time domain) 3D Electric fields caused by 
time dependent voltage, current and charge distributions. All 
1-2 Introduction 
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sources are artibrary functions of time.
In addition, Maxwell may be coupled with other simulators to 
provide a greater range of solution capability. Couplings to 
ePhysics for thermal and stress analysis, HFSS for ferrite anal-
ysis, and Simplorer for Finite Element/Circuit co-simulation 
are all supported.

The Maxwell Desktop
The following graphic shows the different sections of the Max-
well desktop:

Progress WindowMessage Window

Modeler Window

History 
Tree

Status Bar

Toolbars

Project 
Manager 
Window

Properties 
Window 
(Docked)

Menu
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General Procedure for Setting Up Maxwell 
Designs
You are not required to follow a specific order when setting 
up your Maxwell design (as was required for Maxwell Version 
10 and earlier). However, the following order is recom-
mended, particularly for new users:
1  Open Maxwell by double-clicking the desktop icon or by 

clicking Start>Programs>Ansoft>Maxwell14.0>Maxwell 
14.0from the Windows taskbar.

2  Save a new project.
3  Draw the geometry of the model.
4  Optionally, modify the model's design parameters.
5  Assign variables to design parameters.
6  Assign excitations and boundary conditions.
7  Specify solution settings.
8  Run a Maxwell simulation.
9  Create post-processing plots.
10  Create a parametric analysis.
11  Create a field animation of the parametric analysis 

results.
1-4 Introduction 
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About the Example Design
The application described in this Getting Started guide is an 
extension of the TEAM Workshop Problem 24 rotational actua-
tor design. The geometry is shown below:

The outer part is a ferromagnetic nonlinear armature carrying 
two coils. The inner part is made of the same nonlinear mate-
rial and can rotate around an axis. The inner and outer parts 
of the device are co-axial.
The field distribution will likely cause the flux density to con-
centrate in the two steel armatures in the regions where the 
distance between them is minimal. The expected edge effect 
will then further increase the field concentration. 
Introduction 1-5
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In this example, we will compute the torque acting on the 
inner armature and the flux linkage of the two coils. For a 
presentation of the results and the corresponding FEM code, 
see the IEEE Transactions on Magnetics, Vol 38, No. 2, March 
2002, pp 609-612.
1-6 Introduction 



2 Setting Up the Design
In this chapter you will complete the following tasks:
Open and save a new project.
Insert a new Maxwell design into the project.
Select a solution type for the project.
Set the drawing units for the design.
Setting Up the Design 2-1
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Open Maxwell and Save a New Project
A project is a collection of one or more designs that is saved 
in a single *.mxwl file. A new project is automatically created 
when Maxwell is launched. 
Open Maxwell, add a new design, and save the default project 
with a new name.
To open Maxwell and save a project:
1  Double-click the Maxwell 14.0 icon on your desktop to 

launch Maxwell.

• You can also start Maxwell by clicking Start>Pro-
grams>Ansoft>Maxwell14.0>Maxwell14.0 from Win-
dows.

2  Click Project>Insert Maxwell 3D Design.
The new design is listed in the project tree. By default, it 
is named Maxwell3DDesign1. The Modeler window 
appears to the right of the Project Manager (another name 
for the project tree). 

3  Click File>Save As.
The Save As dialog box appears.

4  Locate and select the folder in which you want to save the 
project.

5  Type Rotational_actuator in the File name box, and click 
Save.

6  The project is saved in the specified folder under the 
name Rotational_actuator.mxwl.Rename the design:
a. Right-click Maxwell3DDesign1.

A shortcut menu appears.
b. Select Rename.

The design name becomes highlighted and editable.
c. Type a Rotational_actuator as the name for the design, and 

press Enter.
The project and design are now both named 
Rotational_actuator.

To save your proj-
ect frequently, click 
File>Save.

You can add addi-
tional designs to the 
project by repeating 
step 2 above, or by 
clicking the corre-
sponding icon on the 
toolbar. For the cur-
rent simulation task, 
we do not need to 
create additional 
designs.

If you want a new 
Maxwell design to be 
automatically inserted 
every time you open 
Maxwell, do the fol-
lowing: Click Tools>
Options>General 
Options, and click the 
Project Options tab. 
Select the Insert a 
design of type radio 
button, and select 
Maxwell3D from the 
pull-down list. Click 
OK.

For More Information 
see the Online Help 
Topic: 

General Options: 
Project Options Tab
2-2 Setting Up the Design 
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Specify a Solution Type
As mentioned in the introduction, multiple solution types are 
available, depending on the specific application. For this 
design, choose a Magnetostatic solution.
1  Click Maxwell3D>Solution Type from the menus.

The Solution Type dialog box appears.

2  Select the Magnetostatic radio button. 
3  Click OK.

Set the Drawing Units
1  Click Modeler>Units.

The Set Model Units dialog box appears.

2  Select mm from the Select units pull-down menu.
3  Click OK.

Project Manager
Window 
Setting Up the Design 2-3
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3 Creating the 
Geometric Model
In this chapter you will complete the following tasks:
Set the drawing plane and movement mode.
Create the outer armature of the actuator by 
subtracting and uniting objects.
Create the inner armature of the actuator.
Create the coils.
Create the coil terminals.
Create the background object.
Finalize the geometry by rotating the inner arm.
Creating the Geometric Model 3-1
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Set the Drawing Plane and Movement 
Mode
Before creating the geometry, make sure the XY drawing 
plane is selected and 3D is selected as the movement 
mode.These options are on the 3D Modeler toolbar. 

To set the drawing plane:
•    Select XY from the Drawing plane pull-down list on the 

3D Modeler Draw toolbar.
To set the movement mode:
•    Select 3D from the Movement mode pull-down list on the 

3D Modeler Draw toolbar.
3-2 Creating the Geometric Model 
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Create the Outer Armature Object
The outer armature consists of two cylinders (for an outer and 
inner radius) that are subtracted to leave the armature. Mag-
netic poles are then added to the armature object.

Draw the Outer Cylinder
Create the outer radius of the outer armature object.
To create the outer cylinder:
1  Click Draw>Cylinder.

The cursor changes to a small black box, indicating that 
you are in Drawing mode.

2  Select the center of the cylinder by clicking at the (0,0,0) 
location, which is the origin for the coordinate system, 
and press the Tab key to jump to the manual entry area in 
the Status Bar at the bottom of the screen.

3  Notice the Status Bar is prompting for Radius of the cylin-
der. Type 104.5 for the radius in the dX box, and ensure 
that dY and dZ are set to zero. Press Enter.

4  The Status Bar is now prompting for height of the cylinder. 
Type 25.4 for the height in the dZ box, and press Enter. 
The cylinder is created and the default properties appear 
in the Properties Window.

5  In the Attribute tab, change the Name (currently 
Cylinder1) to Outer_arm. 

6  Change the color of the cylinder to red:
a. In the Color row, click the Edit button.

The Color palette dialog box appears.
b. Select any of the red shades from the Basic colors group, and 

click OK to return to the Properties window.

Note Optionally, you may use the pop-up Properties Window 
by configuring user options. 
Creating the Geometric Model 3-3
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7  Set the transparency to 0.6:
a. Click the button for the Transparent property.

The Set Transparency dialog box appears.
b. Type 0.6 in the text box, and click OK to return to the Proper-

ties window.
8  Optionally, click the Command tab to view and edit the 

geometric data. For this example, we do not need to edit 
the geometric data.

9  Optionally, when using the pop-up Properties dialog, click 
OK to close the Properties window. A cylinder named 
Outer_arm is drawn. 

Note You can also view the Command tab by double-clicking 
the CreateCylinder entry in the history tree window.
3-4 Creating the Geometric Model 
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View the Entire Cylinder
It is easier to view the model you are drawing if you set it to 
fit the screen.
To fit the entire model on the screen:
•    Click View>Fit All>All Views or use the keyboard shortcut 

Ctrl+D.

Draw the Inner Cylinder
Add the inner radius for the outer armature object.
To create the inner cylinder:
1  Click Draw>Cylinder.

The cursor changes to a small black box, indicating that 
you are in Drawing mode.

2  Select the center of the cylinder by clicking at the (0,0,0) 
location, which is the origin for the coordinate system. 
Press Tab to navigate to the keyboard entry area on the 
Status Bar.
Creating the Geometric Model 3-5



Getting Started with Maxwell: Designing a Rotational Actuator
3  Type 83.1 for the radius in the dX box at the bottom of 
the screen, and press Enter.

4  Type 25.4 for the height in the dZ box, and press Enter.
The Properties window appears.

5  Click the Attribute tab.
6  Change the Name to Cylinder_tool. 
7  Click OK when you are done making any desired edits.

The Properties window closes.

Subtract the Cylinders
Subtract Cylinder_tool from Outer_arm.
To subtract the second cylinder from the first:
1  In the history tree, select the Outer_arm cylinder, press 

and hold down Ctrl, and select the Cylinder_tool cylinder.

2  Click Modeler>Boolean>Subtract.
The Subtract dialog box appears.

3  If necessary, move the Outer_arm object to the Blank 
Parts list and the Cylinder_tool object to the Tool Parts 
list. To move an object from one list to another, select it, 
and click the appropriate arrow.

4  Click OK.

Add the Poles to the Outer Armature 
Add two magnetic poles to the outer armature. To do so, you 
need to create a box, move the box into the position for the 
poles, and use the Mirror command to create a duplicate of 

Note Use the Tab key to navigate between value fields (from X 
to Y to Z and from dX to dY to dZ).

Note The first object selected appears under Blank Parts, and 
the second object selected appears under Tool Parts. 
Tool parts are removed during a Boolean operation 
(unless cloned) and the final part takes on the name and 
other characteristics of the Blank Part. 
3-6 Creating the Geometric Model 
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the box. Then unite the three model objects, and subtract a 
newly created cylinder to arrive at the final shape.
To create the box for the outer armature magnetic poles:
1  Click Draw>Box.

2  Type the box position (-13.9, 0, 0) in the X, Y, and Z fields 
at the bottom of the screen, and then press Enter.

3  Type the box size (27.8, -40, 25.4) in the dX, dY, dZ 
fields, and then press Enter.
The Properties window appears.

4  Click OK.
A box named Box1 is drawn.

Move the Box into a Pole Position
To move the box into the correct position for one of the mag-
netic poles:
1  Select Box1 from the history tree.

2  Click Edit>Arrange>Move.
3  Type (0, 0, 0) in the (X, Y, Z) fields as the origin of the 

move vector, and press Enter.
4  Type (0, -45, 0) in the (dX, dY, dZ) fields as the target 

point of the move vector, and press Enter.

Create a Duplicate of the Pole Box
To create a duplicate of the box using mirroring:
1  Select Box1 from the history tree.

2  Click Edit>Duplicate>Mirror.
3  Type (0, 0, 0) in the (X, Y, Z) fields as coordinates for the 

anchor point on the mirror plane, and press Enter.
4  Type (0, 1, 0) in the (dX, dY, dZ) fields as coordinates of 

target point of the vector normal to the mirror plane, and 
press Enter.

A second box, named Box1_1, is drawn.
Creating the Geometric Model 3-7
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Unite the Outer Armature and Magnetic Pole 
Boxes
To unite the three objects in the model:
1  In the history tree window, select Outer_arm, hold down 

the Ctrl key, and then select Box1 and Box1_1.

2  Select Modeler>Boolean>Unite.
The first selected object was Outer_arm; therefore, the 
default name for the final object is Outer_arm. 

Finalize the Outer Armature Magnetic Pole Faces
To provide the final shape for the magnetic pole faces:
1  Create a cylinder with the center at (0, 0,0), a radius of 

53.75, and a height of 25.4:

a. Click Draw>Cylinder.
The cursor changes to a small black box, indicating that you are in 
Drawing mode.

b. Select the center of the cylinder by clicking at the (0,0,0) loca-
tion, which is the origin for the coordinate system. Tab to the key-
board entry area.

c. Type 53.75 for the radius in the dX box at the bottom of the 
screen, and press Enter.

d. Type 25.4 for the height in the dZ box, and press Enter.
The Properties window contains the properties of the new cylin-
der, cylinder1.

2  Since we will be using a similar cylinder in the next sec-
tion, we will make a copy of cylinder1 for later use.
a. Select cylinder1.
b. Click Edit>Copy to create a copy of the object on the clipboard.
c. Next select Edit>Paste to paste a new copy, named cylinder2 in 

the history tree, into the project at the same location as the original.
3  Subtract cylinder1 from Outer_arm to achieve the curved 

edges on the poles:
a. Select the Outer_arm object, press and hold the Ctrl key, and 

then select cylinder1.
b. Select Modeler>Boolean>Subtract.

The Subtract dialog box appears.
3-8 Creating the Geometric Model 
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c. Make sure the Outer_arm object is in the Blank Parts list and 
the cylinder1 object is in the Tool Parts list.

d. Click OK.
The Outer_arm object should look as shown in the following 
graphic:

4  Click File>Save to save all of the operations up to this 
point.

Note Pressing F1 with any dialog on the screen will open the 
Context-Sensitive Help system to the appropriate page 
for that dialog.
Creating the Geometric Model 3-9
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Create the Inner Armature Object
The inner armature consists of two cylinders (for an outer and 
inner radius) that are subtracted to leave the armature. Mag-
netic poles are then added to the armature object.

Draw the Inner Armature Cylinders
To draw the inner armature:
1  Create a cylinder called shaft with the following proper-

ties.

Step by Step instructions if needed:
a. Click Draw>Cylinder.
b. Select the center of the cylinder by clicking at the (0,0,0) loca-

tion, which is the origin for the coordinate system. Tab to the key-
board entry area on the Status Bar.

c. Type 25.4 for the radius in the dX box at the bottom of the screen, 
and press Enter.

d. Type 25.4 for the height in the dZ box, and click Enter.
The Properties window appears.

e. Click the Attribute tab.
f. Change the Name to shaft. 
g. Click OK.

A cylinder named shaft is drawn.
2  The properties of cylinder2 can be modified to create the 

outer radius of the inner armature to eliminate the need 
to draw another object.
a. Select the CreateCylinder command in the history tree under the 

cylinder2 object.

Property Value
Center (0, 0, 0)

Radius(dX) 25.4mm

Height(dZ) 25.4mm
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b. In the Properties Window, select the Command tab.
c. Select the value field containing 53.75 corresponding to Radius. 

The field becomes highlighted and editable.
d. Change the value to 38.1 and press Enter. The radius of cylinder2 

is changed in the modeler window.
e. In the history tree, select cylinder2. The Attribute tab is now visi-

ble in the Properties Window.
f. Change the name of the object by selecting cylinder2 in the value 

field corresponding to Name and entering Inner_arm. Press 
Enter.

g. Subtract shaft from Inner_arm:
h. Select Inner_arm, press and hold down the Ctrl key, and select 

shaft.
i. Select Modeler>Boolean>Subtract from the menu bar.

The Subtract dialog box appears.
j. Make sure Inner_arm is in the Blank Parts list and shaft is in 

the Tool Parts list.
k. Click OK.
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Add the Poles to the Inner Armature 
To create two magnetic poles for the inner armature, you 
need to create another box, move the box into the correct 
position, and use the Mirror command to create a duplicate 
of the box. Unite the inner armature with the two boxes, and 
intersect it with a cylinder to arrive at the final shape.
To create a box for the inner armature magnetic poles:
1  Click Draw>Box.

2  Type the box position (-12.7, 0, 0) in the X, Y, and Z fields 
at the bottom of the screen, and then press Enter.

3  Type the box size (25.4, -20, 25.4) in the dX, dY, dZ 
fields, and then press Enter.
The Properties window appears.

4  Click OK.
A box named Box2 is drawn.

Move the Box into Position
To move the box into position:
1  Select Box2 from the history tree.

2  Select Edit>Arrange>Move.
3  Type (0, 0, 0) in the (X, Y, Z) fields as the origin of the 

move vector, and press Enter.
4  Type (0, -35, 0) in the (dX, dY, dZ) fields as the target 

point of the move vector, and press Enter.
The Properties window appears.

5  Click OK.

Create a Duplicate of the Box
To create a duplicate of the box using mirroring:
1  Select Box2 in the history tree.

2  Select Edit>Duplicate>Mirror.
3  Type (0, 0, 0) in the (X, Y, Z) fields as coordinates for the 

anchor point on the mirror plane, and press Enter.
4  Type (0, 1, 0) in the (dX, dY, dZ) fields as coordinates of 

target point of the vector normal to the mirror plane, and 
press Enter.
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The Properties window appears.
5  Click OK.

A box named Box2_1 is drawn.

Unite the Inner Armature and Magnetic Pole 
Boxes
To unite the inner armature object with the two boxes:
1  In the history tree, select Inner_arm, press and hold down 

the Ctrl key, and then select Box2 and Box2_1.

2  Select Modeler>Boolean>Unite.
Because the first selected object was Inner_arm, the final 
object name is Inner_arm. The name of the objects can 
be changed in the Properties window on the Attribute 
tab.

Finalize the Inner Armature Magnetic Pole Faces
To provide the final shape for the magnetic pole faces:
1  Create a cylinder with the center at (0, 0,0), a radius of 

51.05, and a height of 25.4:

a. Click Draw>Cylinder.
The cursor changes to a small black box, indicating that you are in 
Drawing mode.

b. Select the center of the cylinder by clicking at the (0,0,0) loca-
tion, which is the origin for the coordinate system.

c. Type 51.05 for the radius in the dX box at the bottom of the 
screen, and press Enter.

d. Type 25.4 for the height in the dZ box, and press Enter.
The Properties window appears.

e. Click the Attribute tab.
f. Change the Name to finalpole2. 
g. Click OK.

A cylinder called finalpole2 is drawn.
2  Intersect Inner_arm and the new finalpole2 object:

a. In the history tree, select the Inner_arm object, press and hold 
down the Ctrl key, and then select finalpole2.

b. Select Modeler>Boolean>Intersect.
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The final armatures should look like the following:

3  Click File>Save to save all of the operations up to this 
point.
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Create the Coils
First create a new coordinate system (RelativeCS1) so that in 
the new coordinate system the XY plane becomes a median 
plane of the model. Then create a cross-section of the coils 
and sweep it across a path that will create the 3D coils. Then 
intersect the coil shape with a cylinder and create a dupli-
cate, to achieve the final coil shape.

Create the New Coordinate System
To create the new coordinate system:
1  Select Modeler>Coordinate System>Create>Relative 

CS>Offset.

2  Press the Tab key to switch to the keyboard entry area of 
the Status Bar. Type the new origin (0, 0, 12.7) in the (X, 
Y, Z) boxes, and then press Enter.
The new coordinate system is created and named 
RelativeCS1.

Sweep a Cross-Section Across a New Path
The coil(s) are created by sweeping the coil cross-section 
along a path. 

Set the Drawing Plane to ZX
To set the drawing plane:
•    Select ZX from the Drawing plane pull-down list on the 3D 

Modeler Draw toolbar.

Draw the Sweep Path
To create the path you want to use as the sweep path:
1  Click Draw>Rectangle.

2  Tab to the keyboard entry area and type (-17, 0, -15.5) in 
the (X, Y, Z) boxes, for the rectangle position, and then 
press Enter.

3  Type (34, 0, 31) in the (dX, dY, dZ) boxes, for the rectan-
gle dimensions, and press Enter.
The Properties window appears.

4  Click the Attribute tab.
5  Change the Name to path. 
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6  Click OK.
A rectangle named path is drawn.

7  Uncover the faces:
a. Click Edit>Select>Faces, and select path by clicking on it in 

the Modeler window. 
b. Click Modeler>Surface>Uncover Faces.

Set the Drawing Plane to YZ
To set the drawing plane:
•    Select YZ from the Drawing plane pull-down list on the 3D 

Modeler Draw toolbar.

Draw the Cross-Section of the Coil
To draw the cross-section of the coil:
1  Click Draw>Rectangle to draw the cross-section of the 

coil.

2  Type (0, 0, 15.5) in the (X, Y, Z) boxes, for the rectangle 
position, and then press Enter.

3  Type (0, 17, 24) in the (dX, dY, dZ) boxes, for the rectan-
gle dimensions, and press Enter.
The Properties window appears.

4  Click the Attribute tab.
5  Change the Name to coil1. 
6  Click OK.

A rectangle named coil1 is drawn.

Sweep the Cross-Section Along the Path
To sweep the cross-section (coil1) along the path (path) to 
create the coil:
1  In the history tree, select path, press and hold down the 

Ctrl key, and then select coil1.

2  Click Draw>Sweep>Along Path.
The Sweep along path dialog box appears.

3  Click OK to accept the defaults.
The Properties window appears.

4  Click OK to create the coil. The coil retains the name coil1 
from the cross section used to create it.
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Set the Drawing Plane Back to ZX
To set the drawing plane:
•    Select ZX from the Drawing plane pull-down list on the 3D 

Modeler Draw toolbar.
Creating the Geometric Model 3-17



Getting Started with Maxwell: Designing a Rotational Actuator
Intersect the Coil Shape with a Cylinder
The final coil shape has rounded outside corners. 
Using the new coordinate system, RelativeCS1, do the follow-
ing to achieve the final shape:
1  Create a cylinder at the origin with a radius (dZ) of 43 mm 

and a height (dY) of 17 mm:

a. Click Draw>Cylinder.
The cursor changes to a small black box, indicating that you are in 
Drawing mode.

b. Select the center of the cylinder by clicking at the (0,0,0) loca-
tion, which is the origin for the coordinate system.

c. Type 43 for the radius in the dZ box at the bottom of the screen, 
and press Enter.

d. Type 17 for the height in the dY box, and press Enter.
The Properties window appears.

e. Click the Attribute tab.
f. Change the Name to round. 
g. Click OK.

A cylinder named round is drawn.
2  Intersect the coil and the new cylinder:

a. In the history tree, select coil1, press and hold down the Ctrl key, 
and then select round.

b. Click Modeler>Boolean>Intersect.
The intersected object is named coil1.

Move the Coil into the Final Position
To move the coil into its final position.
1  Select coil1 in the history tree window.

2  Select Edit>Arrange>Move.
3  Type (0, 0, 0) in the (X, Y, Z) fields, for the origin of the 

new location, and then press Enter.
4  Type (0, 54.5, 0) in the (dX, dY, dZ) fields as the target 

point of new dimensions, and press Enter.
The Properties window appears.

5  Click OK.
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Create a Mirror Duplicate of the Coil
To create a second coil by mirroring the first:
1  Select coil1 in the history tree window.

2  Select Edit>Duplicate>Mirror.
3  Type (0, 0, 0) in the (X, Y, Z) fields as the coordinates of 

the anchor point on the mirror plane, and then press 
Enter.

4  Type (0, 1, 0) in the (dX, dY, dZ) fields as coordinates of 
the target point of the vector normal to the mirror plane, 
and press Enter.
The Properties window appears.

5  Click OK.
A second coil is created and named coil1_1.

Create the Coil Terminals
To create the terminals for the coils:
1  In the history tree, select coil1, press and hold down the 

Ctrl key, and select coil1_1.

2  Click Modeler>Surface>Section.
3  Select XY as the Section Plane.
4  Click OK.
5  Click Modeler>Boolean>Separate Bodies. This separates 

the interlinked sheet objects created when the intersec-
tion of the XY plane created two terminals in each coil. 
The resulting four objects are automatically named

•    Coil1_Section1
•    Coil1_Section1_Separate1
•    Coil1_1_Section1
•    Coil1_1_Section1_Separate1
6  Delete the two redundant terminals:

a. In the history tree window, select 
Coil1_Section1_Separate1, press and hold down the Ctrl 
key, and select Coil1_1_Section1_Separate1.

b. Press Delete.
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7  Double-click on Coil1_Section1 in the Sheets section of 
the history tree. 
The Properties window is displayed.

8  Change the name of Coil1_Section1 to Section1 and click 
OK.

9  Repeat steps 8 and 9 to change the name of 
Coil1_1_Section1 to Section2.

Create the Background (Region)
Define a background region box with the origin at (-250, -250, 
-250) and the dimensions of (500, 500, 500).
To create the background region box:
1  Click Draw>Box.

2  Type the box position (-250, -250, -250) in the X, Y, and Z 
fields at the bottom of the screen, and then press Enter.

3  Type the box size (500, 500, 500) in the dX, dY, dZ fields, 
and then press Enter.
The Properties window appears.

4  Click the Attribute tab.
5  Change the Name (currently Box3) to bgnd. 
6  Set the transparency to 0.9:

a. Click the button for the Transparent property.
The Set Transparency dialog box appears.

b. Type 0.9 in the text box, and click OK to return to the Proper-
ties window.

7  Click OK.
A box named bgnd is drawn.

8  Press Ctrl-D to fit the drawing in the window.

Finalize the Geometry
To finalize the geometry:
1  Select the Inner_arm object in the history tree.

Note Alternatively, the Draw>Region command may be used 
to create the background object. 
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2  Click Edit>Arrange>Rotate.
The Rotate dialog box appears.

3  Select the Z radio button for the Axis.
4  Thinking ahead, we will want to evaluate the device over a 

range of armature angles. Therefore, enter “angle” into 
the value field.
The Add Variable dialog appears as shown to specify the 
value for the variable.

5  Ensure that the Unit Type is set to Angle, and the Unit is 
set to deg. Type 29 in the Value text box.

6  Click OK.

Note Most numeric entry fields allow entry of a variable name 
for use in parametric or optimization.
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The final geometry should look similar to the following:

7  Click File>Save to save the final version of the model 
before moving on to defining materials.
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4 Defining Material 
Properties
In this chapter you will complete the following tasks:
Define material properties.
Assign excitations.
Set up torque and inductance parameter 
calculations.
Set up a matrix.
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Define Material Properties
Default material properties are automatically assigned when 
you create the geometry objects. You can view these proper-
ties by viewing the Attribute tab of the Properties window. 
The default material for all objects is vacuum, which can be 
changed as soon as you draw an object. For this example, you 
will set the material definitions for all objects at the same 
time after the entire geometry has been created.

Define the Nonlinear Material for the Two 
Armatures
To define the nonlinear material for the armatures:
1  Double-click the Outer_arm object in the history tree.

The Properties window appears.
2  In the Material row, click the value in the Value column.

A drop-down list appears.
3  Select the Edit... item in the list.

The Select Definition dialog box appears.
4  On the Materials tab, click the Add Material button.

The View / Edit Material dialog box appears.
5  Type arm_steel in the Material Name box. 
6  Do the following in the Properties of the Material section:

a. In the Type column of the Relative Permeability row, select 
Nonlinear from the pull-down list.

b. In the Value column of the Relative Permeability row, click 
the BH Curve button.
The BH Curve dialog box appears. By default, 10 rows are avail-
able to enter data points, but this example requires 20.
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c. In the Coordinates section, append 10 additional rows to the 
table to reach a total of 20 data rows:
• Click the Append Rows button.
• Type 10 in the Number of rows text box, and click OK.

The BH Curve dialog box reappears, with 20 rows now avail-
able in the table.

d. Type the following H and B data in the Coordinates section:

Note When entering data into the Coordinates section, the 
Tab key can be used to sequentially move to the next 
entry position.

H (A/m) B (T)
1. 0 0

2. 4000 1.413

3. 8010 1.594

4. 16010 1.751

5. 24020 1.839
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e. Click OK.
The BH Curve dialog box closes, and the View / Edit Mate-
rial dialog box reappears.

f. In the Value column of the Bulk Conductivity row, enter 2e6.
g. Click Validate Material.

A green check mark appears if the material is valid.
7  Click OK to close the View / Edit Material dialog box.

The Select Definition dialog box reappears.
8  Click OK to close the Select Definition dialog box.

The Properties window reappears.
9  Click OK to close the Properties window.

Assign Material Properties
Select the Inner_arm object, and assign the newly defined 
arm_steel property. Select the two coils, and assign copper 
as the material property:
To assign the material properties to the model objects:
1  Double-click the Inner_arm object in the history tree.

The Properties window appears.

6. 32030 1.896

7. 40030 1.936

8. 48040 1.967

9. 64050 2.008

10. 80070 2.042

11. 96080 2.073

12. 112100 2.101

13. 128110 2.127

14. 144120 2.151

15. 176150 2.197

16. 208180 2.24

17. 272230 2.325

18. 304260 2.37

19. 336290 2.42

20. 396000 2.5
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2  In the Material row, click the field in the Value column.
A drop-down list of available materials appears.

3  Select arm_steel from the list of materials.
4  Click OK to close the Properties window.
5  Repeat steps 1 through 4 to assign copper to coil1.
6  Repeat steps 1 through 4 to assign copper to coil1_1.
7  Leave the material assignment for the background object 

unchanged.

Assign Excitations
Currents need to be defined and assigned as excitations for 
the two coil terminals.
To define the currents:
1  Select Section1 and Section2 in the history tree.

2  Click Maxwell3D>Excitations>Assign>Current from the 
menu.
The Current Excitation dialog box appears.

3  Type 675.5 in the Value text box, and select A as the 
units.

4  Select Stranded as the Type.
5  Click OK.
By default, all faces of the region box (background) are 
assigned with magnetic flux tangent boundary conditions. 
Therefore, no additional boundary conditions are required for 
this example problem.

Note Excitations may also be assigned using the shortcut 
menu. Right-click on Excitations in the Project tree. In 
the Shortcut menu, select Assign>Current.
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Set Up Parameter Calculations
In this example, you will calculate the torque and inductance 
matrix parameters.

Set Up the Torque Calculation
To set up the torque calculation:
1  Select the Inner_arm object by clicking its name in the 

history tree window.

2  In the project tree, right-click Parameters row.
A shortcut menu appears.

3  Select Assign>Torque from the shortcut menu.
The Torque dialog box appears.

4  Leave the Type set to Virtual.
5  Select Global:Z from the Axis pull-down list.
6  Select the Positive radio button for the axis orientation.
7  Click OK.

Set Up the Inductance Matrix Calculation
To set up the inductance matrix calculation:
1  Right-click the Parameters field in the project tree.

A shortcut menu appears.

2  Select Assign>Matrix from the shortcut menu.
The Matrix dialog box appears.

3  Click the Setup tab.
4  Select Include for both coil1 and coil1_1 for the induc-

tance calculations to be performed. The self inductances 
and mutual inductances will be calculated.

5  Click OK.
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Exploring the Matrix Setup Grouping Functionality
The matrix setup provides a grouping functionality on the 
Post Processing tab:

Thus, in addition to inductance matrix entries calculation, 
Maxwell can perform a grouping calculation.
To perform a grouping calculation:
1  Select the matrix entry and specify the corresponding 

number of turns.

2  Select all matrix entries to be involved in grouping and 
click the Group button.

3  Specify the number of branches.
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The operations performed by the grouping function can be 
one of the three cases:

• Series connection if the number of branches is set to 1.
• Parallel connection if number of branches is equal with the total 

number of coils (matrix entries).
• Series/parallel if the number of branches is different from the two 

above.

Example 1: Series/Parallel
Assume a situation with 4 coils, each with 18 turns, all 4 
selected to be grouped with the number of branches set to 2. 
In this case, 9 turns from each of the 4 coils (18 / 2 branches 
= 9) are connected in series and paralleled, with the other 9 
turns of the same coils also connected in series.

Example 2: Series/Parallel
Assume a situation with 5 coils, each with 15 turns and num-
ber of branches set to 3. In this case, the equivalent S/P cor-
responds to taking the first 5 turns from each of the 5 coil and 
connecting them in series, taking the next 5 turns from the 
same coils and connecting them in series, taking the final 5 
turns from the coils and connecting them in series, and then 
finally connect the emerging 3 subgroups in parallel.

Note For the grouping in the S/P case to correspond to a physical 
situation, the number of turns must be an integer multiple of 
the number of branches.
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5 Setting Up and 
Running the Analysis
In this chapter you will complete the following tasks:
Set up the analysis.
Run and solve the analysis.
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Set Up the Analysis
To set up the analysis:
1  Right-click the Analysis field in the project tree.

A shortcut menu appears.

2  Select Add Solution Setup. 
The Solve Setup dialog box appears.

3  Click the General tab.
4  Accept the default values (Maximum number of passes = 

10 and Percent Error = 1). 
These settings instruct the solver to solve up to 10 passes 
as the automatic adaptive mesh refinement refines the 
mesh and improves the accuracy of the solution at run 
time.

5  Click OK.

Run the Analysis
To run the analysis:
1  Right-click the Analysis field in the project tree.

A shortcut menu appears.

2  Select Analyze All. 
3  To visualize the progress of the solution:

a. Right-click the Setup1 field (located under the Analysis field), 
and select Convergence. 

b. Make sure the Convergence tab is selected.
c. Select a tabular or graphical format for how to visualize the infor-

mation about the energy, number of finite elements, torque, etc.
d. Click OK.

4  When the solution is complete (it should take between 3 
and 5 minutes on most PCs), look at the value of the 
torque from LastAdaptive. 
The value should be about -0.173 N m.
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6 Post Processing the 
Results
In this chapter you will complete the following task:
Plot the magnetic flux density vector.
Plot the magnetic flux density magnitude.
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Plot the Magnetic Flux Density Vector 
Plot the flux density vector on the mid-vertical symmetry 
plane of the device. You previously set up a relative coordi-
nate system (RelativeCS1) containing the desired plot plane. 

Create an Object List
Since we want to plot the results only in the two armatures, 
create a list of these two objects to prepare for the plot.
To create the list of objects:
1  Select the Outer_arm and Inner_arm objects.

2  Click Modeler>List>Create>Object List.
ObjectList1 is created under the Lists section of the His-
tory Tree.

Plot the Quantity
To create the plot:
1  Change the rendering of objects in the model to wireframe 

by clicking View>Render>Wire Frame.

2  In the history tree, select the RelativeCS1:XY plane under 
Planes. This will be the plane to create plots on.

3  In the project tree, right-click Field Overlays, and select 
Fields>B>B_Vector.
The Create Field Plot dialog box appears.

4  Make sure B_Vector is selected in the Quantity list.
5  Select Objectlist1 in the In Volume list. 
6  Click Done.
7  Click Maxwell3D>Fields>Modify Plot Attributes.

The Select Plot Folder dialog box appears.
8  Select B from the list, and click OK.

A dialog box appears where you can modify the plot attri-
butes.

9  Click the Scale tab.
10  Select the Use Limits radio button.
11  Type 2.1338E-006 in the Min box, and type 7.5E-001 in 

the Max box.
12  Click the Plots tab.
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13  Under the Vector Plot parameters slide the Spacing rule 
all the way to the left and enter 4 in the min box.

14  Click Apply, and then click Close.
The plot should look similar to the figure below:

Plot the Magnetic Flux Density Magnitude
To avoid overlapping with the previous plot, right-click the 
name of the previous plot(B_Vector) under Field Overlays, 
and un-check the Plot Visibility box.
Follow the procedure used to create the previous plot to plot 
the magnetic flux density magnitude(B_Mag) on the same XY 
plane of the RelativeCS1 coordinate system. 
1  Once the plot is displayed, right-click in the color key and 

select Modify.

2  In the Scale tab, set the Number of divisions to 100 to get 
a smooth plot.

3  Click Close.
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The plot should look similar to the figure below:
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7 Running a Parametric 
Analysis
 

In this chapter you will complete the following tasks:
Run a parametric analysis.
Create an analysis report.
Close the project and exit Maxwell.
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Parameterization and Parametric Analysis
Parameters can be easily added to the setup for the purpose 
of changing assigned values (making "what if" type of analysis 
easy to perform) or for the purpose of setting up and running 
parametric analysis. The quantities that can be parameter-
ized include geometric attributes, material properties, exci-
tations, etc.
In this application we define the rotation angle of the 
Inner_arm object as a parameter and then perform a para-
metric analysis aimed at obtaining the self and mutual induc-
tance of the two coils as well as the torque for a whole range 
of rotation angles. The rotation angle was specified as a vari-
able during the creation of the geometric model.
To define the angle variable as a design parameter:
1  Right-click the Optimetrics row in the project tree.

A shortcut menu appears.

2  Select Add>Parametric from the shortcut menu.
3  In the Setup Sweep Analysis dialog, click Add to add a 

variable to the sweep.
4  Select the variable angle from the drop-down list.
5  Select Linear Step as the type of sweep.
6  Enter 0 deg for the start value, 30 deg for the stop value, 

ans 5 deg for the step value.
7  Click the Add button, and then OK.
8  Select the Calculations tab.
9  Click the Setup Calculations button.
10  In the Add/Edit Calculation window,select Magneto-

static for Report Type, Setup1:LastAdaptive for Solu-
tion, and None for Parameter.

11  Click on the Trace tab.
12  Under Category select the following variables:

a. Select Torque>Torque1.Torque and click Add Calculation.
b. Select L>Matrix1.L(Current_1, Current_1) and click Add Cal-

culation.
c. Select L>Matrix1.L(Current_1, Current_2) and click Add Cal-

culation.

You can also use the 
Design Properties 
command to add new 
variables.

View the design 
variations that will be 
solved in table format 
under the Table tab. 
This enables you to 
visualize the design 
variations that will be 
solved and manually 
adjust sweep points if 
necessary.
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d. Select L>Matrix1.L(Current_2, Current_2) and click Add Cal-
culation.

13  Click Done.
14  Back in the Setup Sweep Analysis window, select the 

Options tab.
15  Select the Save Fields And Mesh check box.
16  Click OK when complete. 

A ParametricSetupn entry is now shown under Optimetrics 
in the project tree.

To start the parametric analysis:
1  Right-click the ParametricSetup1 row in the project tree.

A shortcut menu appears.
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2  Select Analyze.

Create a Parametric Analysis Report
Once the parametric analysis in complete, create analysis 
report:
To create a report:
1  Right-click the Results row in the project tree.

A shortcut menu appears.

2  Select Create Magnetostatic Report>Rectangular Plot.
3  In the New Report window set the Solution to 

Setup1:LastAdaptive and Parameter to None.
4  Under Category select L and hold down the ctrl key and 

select Matrix1.L(Current_1,Current_1), 
Matrix1.L(Current_1,Current_2), and 
Matrix1.L(Current_2,Current_2), and click New Report.

5  Click Close when finished.

Note Because you are solving multiple geometric problems, the 
solution time required will be proportionately longer than 
solving the non-parametric solution in the previous chapter.
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The plot should look similar to the figure below.

The L11 and L22 traces almost overlap. This is normal since 
the respective inductances should be identical.
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Create an Animation Using Saved 
Parametric Field Data
You can perform an animation using the saved data.
To perform an animation:
1  In the project tree, under Field Overlays, select the 

desired field plot that is to be animated (such as the B 
vector field plot created in chapter 6).

2  Right-click the plot, and select Animate.
The Setup Animation dialog box appears.

3  Click the Swept Variable tab.
4  Select the desired variable from the Swept variable pull-

down menu (angle in this case).
5  Select the desired variations from the Select values sec-

tion.
6  Click OK to start the animation process.

The Animation play panel appears, allowing you to pause 
and otherwise control the animation.

7  Click Close to stop the animation display.

Note You can export the animation as an animated .gif or .avi 
file by clicking Export in the Animation play panel.

Note Maxwell can take advantage of computing resources on 
various computers that can be accessed on a local 
network. Using the Distributed Processing option 
(licensed separately), you can solve parametric designs 
in parallel (simultaneously) on multiple user-selected 
computers available on the local network. Please 
contact your Ansoft account manager for details.
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Close the Project and Exit Maxwell
Congratulations! You have successfully completed Getting 
Started with Maxwell: Designing a Rotational Actuator! You 
may close the project and exit the Maxwell software.
1  Click File>Save to save the project.

2  Click File>Close.
3  Click File>Exit to exit Maxwell.
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