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Getting Started with Maxwell: A Transient Problem
Conventions Used in this Guide
Please take a moment to review how instructions and other 
useful information are presented in this guide. 
•    The project tree is the main project area of the Project Man-

ager window. These two terms (project tree and Project 
Manager window) may be used interchangeably in this 
guide.

•    Procedures are presented as numbered lists. A single bullet 
indicates that the procedure has only one step.

•    Bold type is used for the following:

- Keyboard entries that should be typed in their entirety 
exactly as shown. For example, “copy file1” means to 
type the word copy, to type a space, and then to type 
file1.

- On-screen prompts and messages, names of options and 
text boxes, and menu commands. Menu commands are 
often separated by carats. For example, click Max-
well>Excitations>Assign>Voltage.

- Labeled keys on the computer keyboard. For example, 
“Press Enter” means to press the key labeled Enter.

•    Menu commands are often separated by the “>” symbol. 
For example, “Click File>Exit”.

•    Italic type is used for the following:

- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be 
typed in place of the words in italics. For example, 
“copy file name” means to type the word copy, to type a 
space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indicate 
that you should press the keys at the same time. For exam-
ple, “Press Shift+F1” means to press the Shift key and the 
F1 key at the same time.

•    Toolbar buttons serve as shortcuts for executing com-
mands. Toolbar buttons are displayed after the command 
they execute. For example,
 i
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“Click Draw>Line ” means that you can also click the 
Draw Line toolbar button to execute the Line command.
 ii 
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Getting Help

Ansoft Technical Support
To contact the Ansoft technical support staff in your geographi-
cal area, please go to the Ansoft website, http://
www.ansoft.com, click the Contact button, and then click Sup-
port. Phone numbers and e-mail addresses are listed for the 
technical support staff. You can also contact your Ansoft 
account manager to obtain this information.
All Ansoft software files are ASCII text and can be sent conve-
niently by e-mail. When reporting difficulties, it is helpful to 
include specific information about what steps were taken or 
what stages the simulation reached. This promotes more rapid 
and effective debugging.

Context-Sensitive Help
To access online help from the Maxwell user interface, do one 
of the following:
•    To open a help topic about a specific Maxwell menu com-

mand, press Shift+F1, and then click the command or tool-
bar icon.

•    To open a help topic about a specific Maxwell dialog box, 
open the dialog box, and then press F1.
 iii
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1 Introduction
This Getting Started Guide is written for Maxwell begin-
ners and experienced users who would like to quickly re-
familiarize themselves with the capabilities of Maxwell. 
This guide leads you step-by-step through solving and ana-
lyzing the results of a rotational actuator magnetostatic 
problem with motion. 
By following the steps in this guide, you will learn how to 
perform the following tasks:
 Modify a model’s design parameters.
 Assign variables to a model’s design parameters.
 Specify solution settings for a design.
 Validate a design’s setup. 
 Run a Maxwell simulation.
 Plot the magnetic flux density vector.
 Include motion in the simulation.

Note This guide assumes that you have already completed 
the magnetostatic example in Getting Started with 
Maxwell: Designing a Rotational Actuator. If you 
have not, you may use the project in the example 
directory; however, it is strongly recommended that 
you complete the magnetostatic example.

Estimated time to 
complete this guide:
1 hour 30 minutes.
Introduction 1-1
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Maxwell Solution Types
Maxwell® is an interactive software package that uses finite 
element analysis (FEA) to simulate (solve) electromagnetic 
field problems. Maxwell integrates with other Ansoft software 
packages to perform complex tasks while remaining simple to 
use. Maxwell® incorporates both a set of 2D solvers and 3D 
solvers in an integrated user interface. This guide will focus 
on 3D capabilities. 2D problems examples are cover in sepa-
rate 2D Getting Started Guides.

The following six types of stand-alone solutions are supported 
by Maxwell 3D:

• Magnetostatic linear and nonlinear 3D fields caused by 
a user-specified distribution of DC current density and permanent 
or externally applied magnetic fields. Materials can be non-linear 
and anisotropic. Additional quantities that can be computed include 
torque, force, and self and mutual inductances.

• Harmonic (sinusoidal variation in time) steady-state 
magnetic fields with pulsation-induced eddy currents in mas-
sive solid conductors caused by one of the following:
a. A user-specified distribution of AC currents (all with the same 

frequency but with possibly different initial phase angles).
b. Externally applied magnetic fields. 
This solution includes displacement currents for calculating near 
field electromagnetic wave radiation.

• Transient (time domain) magnetic fields caused by per-
manent magnets, conductors, and windings supplied by voltage 
and/or current sources with arbitrary variation as functions of time. 
Rotational or translational motion effects can be included in the 
simulation.

• Electrostatic 3D fields caused by a user-specified distribution of 
voltages and charges in non-conducting regions. Additional quanti-
ties that can be computed include torque, force, and capacitances.

• Electric DC Conduction 3D fields in conductors characterized by 
a spatial distribution of voltage, electric field, and current density. 
Power loss can also be computed. In addition, optional simulation 
of fields in insulating materials is supported.

• Transient (time domain) 3D Electric fields caused by 
time dependent voltage, current and charge distributions. All 
sources are arbitrary functions of time.
1-2 Introduction 
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In addition, Maxwell may be coupled with other simulators to 
provide a greater range of solution capability. Couplings to 
ePhysics for thermal and stress analysis, HFSS for ferrite anal-
ysis, and Simplorer for Finite Element/Circuit co-simulation 
are all supported.

The Maxwell Desktop
The following graphic shows the different sections of the Max-
well desktop:

Progress WindowMessage Window

Modeler Window

History 
Tree

Status Bar

Toolbars

Project 
Manager 
Window

Properties 
Window 
(Docked)

Menu
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General Procedure for Setting Up Maxwell 
Designs
You are not required to follow a specific order when setting 
up your Maxwell design (as was required for Maxwell Version 
10 and earlier). However, the following order is recom-
mended, particularly for new users:
1  Open Maxwell by double-clicking the desktop icon or by 

clicking Start>Programs>Ansoft>Maxwell14.0>Maxwell 
14.0 from the Windows taskbar.

2  Save a new project.
3  Draw the geometry of the model.
4  Optionally, modify the model's design parameters.
5  Assign variables to design parameters.
6  Assign excitations and boundary conditions.
7  Specify solution settings.
8  Run a Maxwell simulation.
9  Create post-processing plots.
10  Create a parametric analysis.
11  Create a field animation of the parametric analysis 

results.
12  Include motion in the transient design.
1-4 Introduction 
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About the Example Design
The application described in this Getting Started guide is an 
extension of the TEAM Workshop Problem 24 rotational actua-
tor design. The geometry is shown below:

The outer part is a ferromagnetic nonlinear armature carrying 
two coils. The inner part is made of the same nonlinear mate-
rial and can rotate around an axis. The inner and outer parts 
of the device are co-axial.
The field distribution will likely cause the flux density to con-
centrate in the two steel armatures in the regions where the 
distance between them is minimal. The expected edge effect 
will then further increase the field concentration. 
In this example, we will compute the torque acting on the 
inner armature and the flux linkage of the two coils. Simula-
tion results show a 3D electromagnetic time-transient prob-
lem with the effects of large motion included. Both the rotor 
and stator are made of solid ferromagnetic steel, creating sig-
nificant eddy current effects. A nonlinear B-H curve is consid-
ered for the stator and rotor steel. The solution includes the 
estimated mechanical rotor inertia. For a presentation of the 

Axial length (rotor and stator) = 25.4

Φ 209.0

Φ 50.8 

Φ 102.1 

Φ 107.5 

27.8 

21.4 
12.7

25.4 
Axial length
and stator)

Coils 
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results and the corresponding FEM code, see the IEEE Transac-
tions on Magnetics, Vol 38, No. 2, March 2002, pp 609-612.
1-6 Introduction 



2 Setting Up the Design
In this chapter you will complete the following tasks:
Open and save a new project.
Insert a new Maxwell design into the project.
Select a solution type for the project.
Set the drawing units for the design.
Setting Up the Design 2-1
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Open Maxwell and Save a New Project
A project is a collection of one or more designs that is saved 
in a single *.mxwl file. A new project is automatically created 
when Maxwell is launched. 
To open Maxwell and save a project:
1  Double-click the Maxwell 14.0 icon on your desktop to 

launch Maxwell.

• You can also start Maxwell by clicking 
Start>Programs>Ansoft>Maxwell 14.0>Maxwell 14.0 
from Windows.

2  Click Project>Insert Maxwell 3D Design.
The new design is listed in the project tree. By default, it 
is named Maxwell3DDesign1. The Modeler window 
appears to the right of the Project Manager. 

3  Click File>Save As.
The Save As dialog box appears.

4  Locate and select the folder in which you want to save the 
project.

5  Type Rotational_Act_TR in the File name box, and click 
Save.
The project is saved in the specified folder under the 
name Rotational_Act_TR.mxwl.

6  Rename the design:
a. Right-click Maxwell3DDesign1.

A shortcut menu appears.
b. Select Rename.

The design name becomes highlighted and editable.
c. Type Rotational_Act_TR as the name for the design, and press 

Enter.
The project and design are now both named 
Rotational_Act_TR.

To save your proj-
ect frequently, click 
File>Save.

If you want a new 
Maxwell design to be 
automatically inserted 
every time you open 
Maxwell, do the fol-
lowing: Click Tools>
Options>General 
Options, and click the 
Project Options tab. 
Select the Insert a 
design of type radio 
button, and select 
Maxwell from the pull-
down list. Click OK.
2-2 Setting Up the Design 
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Specify a Solution Type
As mentioned in the introduction, multiple solution types are 
available, depending on the specific application. For this 
design, choose a Transient solution.
To specify the solution type:
1  Click Maxwell3D>Solution Type.

The Solution Type dialog box appears.

2  Select the Transient radio button. 
3  Click OK.

Project Manager
Window 
Setting Up the Design 2-3
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Set the Drawing Units
To set the drawing units:
1  Click Modeler>Units.

The Set Model Units dialog box appears.

2  Select mm from the Select units pull-down menu.
3  Click OK.
2-4 Setting Up the Design 



3 Importing the 
Geometric Model
In this chapter you will open the Magnetostatic Getting 
Started project, copy the objects definitions and material 
properties, and paste the objects and materials into the 
Rotational_Act_TR transient project. 
If you have not completed the magnetostatic guide Get-
ting Started with Maxwell: Designing a Rotational Actua-
tor, it is strongly recommended that you do so to gain 
necessary knowledge of modeling and material assignment 
principles. You may, however, use the project in the 
example directory. 

In this chapter you will complete the following tasks:
Open the Magnetostatic Getting Started example.
Copy and paste geometry and materials to the 
current project.
Importing the Geometric Model 3-1
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Open the Magnetostatic Project
The geometry and materials used in this project are identical 
to the magnetostatic guide Rotational_Actuator project. 
To open the magnetostatic project:
1  Click File>Open.

The Windows file browser opens.
2  Locate the folder containing the Rotational_actuator 

project from the magnetostatic guide, Getting Started 
with Maxwell: Designing a Rotational Actuator.

3  Select the file Rotational_actuator.mxwl and click Open.
The project is opened and is now listed in the Project Man-
ager Window as shown.
3-2 Importing the Geometric Model 
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Copy and Paste Objects between Projects
The ability to copy and paste objects and their associated 
material assignments is a useful and time saving function of 
the Maxwell software.
In order to copy objects, all objects must be selected.
1  With the Rotational_actuator project in the modeler win-

dow, click in the modeler window and then click 
Edit>Select All to select all object regardless of their visi-
bility status.

The History Tree will expand and highlight all objects in 
the design.

2  Click Edit>Copy to copy the object and material defini-
tions to the clipboard.

3  Click on the Rotational_Act_TR(Transient) design in the 
Project Manager window.

4  Click Maxwell3D>3D Model Editor in the menu to switch 
the Modeler window to the transient project.

5  Click Edit>Paste to paste all objects and material defini-
tions into the transient project.

6  Click Edit>View>Fit All>All Views to fit the objects to the 
window. You may also use the keyboard shortcut Ctrl-D.

7  In the Project Manager window, select the magnetostatic 
project Rotational_Actuator and click File>Close.
Importing the Geometric Model 3-3
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Your screen should look approximately like the one below.

8  Click File>Save to save the model before moving on to the 
next chapter.
3-4 Importing the Geometric Model 



4 Defining the Design 
Properties
For the transient problem, you want to use a pulse excita-
tion to drive the coils. In order to accomplish this, you will 
assign a external current winding excitation to the coils 
and use the Maxwell Circuit Editor to create the external 
driving circuit including a pulse source. You will also allow 
the software to calculate the eddy currents in the solid 
metal objects in the model.

In this chapter you will complete the following tasks:
Verify material properties.
Assign excitations.
Set up an external circuit for the current winding
Set up the mesh operations.
Specify the eddy effect.
Defining the Design Properties 4-1
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Verify Material Properties
Material properties are automatically transferred when you 
copied the geometry objects. You can view these properties 
by viewing the Attribute tab of the Properties window. 
To verify the nonlinear material for the armatures:
1  Expand the History Tree as shown.

2  Double-click the Outer_arm object in the history tree.
The Properties window appears.

3  In the Material row, click the button in the Value column 
labeled arm_steel, then click Edit.
The Select Definition dialog box appears.

4  Click the View/Edit Material button.
The View/Edit Material dialog box appears.

5  In the Relative Permeability row, click the B-H Curve but-
ton.
The BH Curve dialog box appears as shown.
4-2 Defining the Design Properties 
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6  Click Cancel in the BH Curve dialog.
The BH Curve dialog box closes.

7  Continue dismissing dialogs until you have returned to the 
Modeler window.

Assign Excitations
Currents need to be defined and assigned as excitations for 
the two coil terminals.

Define the Currents
To define the currents:
1  Select Section1 and Section 2 in the history tree under 

Sheets.

2  Click Maxwell3D>Excitations>Assign>Coil Terminal.
The Coil Terminal Excitation dialog box appears.

3  Type 350 n the Number of Conductors box.
4  Click OK.
Defining the Design Properties 4-3
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Add a Winding
To add a winding for the excitation:
1  Click Maxwell3D>Excitations>Add Winding.

The Winding dialog box appears.

2  Type currentwinding in the Name box (the default is 
Winding1).

3  Set the Type to External. 
4  Select the Stranded radio button. 
5  Leave the Initial Current set to the default value of 0 

(zero). 

6  Click OK.

Add a Winding Terminal
To add a terminal for the winding:
1  In the project tree, under Excitations, right-click cur-

rentwinding.
A shortcut menu appears.

2  Select Add Terminals from the shortcut menu. 
The Add Terminals dialog box appears.

3  In the list, select CoilTerminal_1, press and hold down 
the Shift key, and select CoilTerminal_2.

4  Click OK. 
In the project tree, the two terminals are moved beneath 
the winding as shown below.

Note We are using an external circuit to supply the excitation 
to the coil. For this example, we also could have used a 
voltage type of excitation.
4-4 Defining the Design Properties 
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Boundary Conditions
The region box (bgnd) by default has all faces assigned with 
magnetic flux tangent boundary conditions. Thus, for this 
problem no additional boundary conditions are needed.

Set Up the External Circuit
The driving circuit for the winding in this design consists of a 
voltage source in series with a resistor and with the winding. 
Defining the Design Properties 4-5
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When complete, the circuit should look similar to the figure 
below.

Add the Circuit Elements
To add the circuit elements in Maxwell Circuit Editor:
1  Open the Maxwell Circuit Editor: 

Click Start>Programs>Ansoft>Maxwell 14.0>Maxwell Cir-
cuit Editor.
The Maxwell Circuit Editor program opens with a default 
circuit sheet as shown below.
4-6 Defining the Design Properties 
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2  Click the Components tab on the project tree window.
3  Place the winding circuit element on the sheet: 

a. In the project tree, under Maxwell Circuit Elements/Dedi-
cated Elements, select the Winding element.

b. Click on, and Drag the Winding element onto the sheet. 
c. Right-click in the Schematic window, and select Finish to exit 

component placement mode. 
d. To view the properties, double-click the component in the Sche-

matic window.
The Properties window appears.

e. Change the Name to currentwinding, the same name you used 
when defining the winding in the Maxwell design.

f. Click OK. 
g. Click Draw>Rotate, and position the winding vertically.
Defining the Design Properties 4-7
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4  Place a resistor on the sheet: 
a. In the project tree, under Passive Elements, select Res:Resis-

tor.
b. Drag the resistor onto the sheet. 
c. Right-click, and select Finish to exit placement mode. 
d. Double-click the symbol of the resistor, change the value of the 

resistor, R, to 3.09, keep the Unit value set to ohm, and click 
OK.

5  Place a voltage pulse on the sheet: 
a. In the project tree, under Sources select a VPulse element (Pulse 

Voltage Source).
b. Drag it to the sheet, and then right-click and select Finish. 
c. Double-click the source element symbol on the sheet, and then 

specify the following source characteristics:

d. Leave the other fields set to the default values, and click OK.

Connect the Circuit Elements in Series
To connect the circuit elements in series:
1  From within the Maxwell Circuit Editor, click Draw>Wire.

2  Click one terminal of the inductor and draw the wire to 
one resistor terminal as shown.

Parameter Value Description

V1 0 Initial voltage

V2 5.97 Peak voltage

Td 0 Initial delay time

Tr 0.001 Rise time

Tf 0.001 Fall time

Pw 1 Pulse width

Period 2
4-8 Defining the Design Properties 
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3  Repeat until a closed circuit is formed.

4  When done, place the Ground symbol: 
a. Click Draw>Ground (or click the Ground symbol on the tool-

bar), 
b. Place the Ground symbol on the sheet as shown below, right-

click, and select Finish. 

Note For the current winding, the “dotted” terminal is positive 
and current is postive when it flows from the “dotted” 
terminal to the “undotted” terminal. Connecting the 
winding as shown results in negative current in the plot in 
the Create a Current vs Time Plot in Chapter 6. You may 
reverse the winding orientation with no change to the 
problem except for the plot which would show positive 
current in that case.
Defining the Design Properties 4-9
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Export the Netlist
To export the netlist:
1  From within the Maxwell Circuit Editor, click Maxwell Cir-

cuit>Export Netlist.
The Netlist Export dialog box appears.

2  Select the folder where you want to save the external cir-
cuit file.

3  Type trans_circ in the File name box.
4  Click Save.

The Netlist Export dialog box closes and the Maxwell Cir-
cuit Editor reappears.

Save the Maxwell Circuit Editor Project
To save the project and exit Maxwell Circuit Editor:
1  Click File>Save, type ExternalCircuit as the name, and 

click Save to save the Maxwell Circuit Editor project.

2  Click File>Exit to close the Maxwell Circuit Editor pro-
gram.

Assign the External Circuit
To assign the circuit in Maxwell (which should still be open):
1  Click Maxwell3D>Excitations>External Circuit>Edit 

External Circuit.

The Edit External Circuit dialog box appears.
2  Click Import Circuit.

The Select File dialog box appears.
3  Select Designer Net List Files (*.sph) from the Files of 

type pull-down list.
4  Browse to the location where you saved the circuit, select 

trans_circ.sph, and click Open to import it. 
5  Click OK to close the Edit External Circuit dialog box.
4-10 Defining the Design Properties 
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Set Up Mesh Operations
This example involves transient magnetic fields in the pres-
ence of massive (solid) conductors, creating eddy currents. To 
catch the effects with reasonable accuracy, a finer mesh is 
required in those objects because skin effects are part of an 
accurate transient solution. 
To seed the mesh to the desired density in the Outer_arm 
and Inner_arm objects:
1  Select Outer_arm from the history tree, press and hold 

down Ctrl, and then select Inner_arm.

2  Click Maxwell3D>Mesh Operations>Assign>Inside Selec-
tion>Length Based.
The Element Length Based Refinement dialog box 
appears.

3  Type 10 in the Maximum Length of Elements box, and 
select mm as the units. 

4  Leave the Restrict the Number of Elements check box 
unchecked. 

5  Click OK. 
This operation refines the mesh at run-time before the tran-
sient problem solution begins. This mesh will be used for all 
time steps; therefore, the mesh density should be appropriate 
for the anticipated field behavior for the entire transient 
analysis.

Specify the Eddy Effect Calculation
Eddy effects can be calculated in objects with non-zero elec-
tric conductivity. 
To calculate eddy effects:
1  Click Maxwell3D>Excitations>Set Eddy Effects.

The Set Eddy Effect dialog box appears.
2  Select the check boxes for the Inner_arm and Outer_arm 

objects.
3  Click OK.
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Specifying Torque Calculation
To set up the torque calculation:
1  Select the Inner_arm object by clicking its name in the 

history tree window.

2  In the project tree, right-click Parameters row.
A shortcut menu appears.

3  Select Assign>Torque from the shortcut menu.
The Torque dialog box appears.

4  Select Global:Z from the Axis pull-down list.
5  Select the Positive radio button for the axis orientation.
6  Click OK.
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5 Setting Up and 
Running the Analysis
In this chapter you will complete the following tasks:
Set up the analysis.
Run and solve the analysis.
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Set Up the Analysis
To set up the analysis:
1  Right-click Analysis in the project tree.

A shortcut menu appears.
2  Select Add Solution Setup. 

The Solve Setup dialog box appears.
3  Click the General tab.
4  Type 0.04 in the Stop time box, and select s as the unit.
5  Type 0.005 in the Time step box, and select s as the unit.
6  To save fields during the solution:

a. Click the Save Fields tab.
b. Select Linear Step from the Type pull-down list to identify the 

type of sweep.
c. Type 0.0 in the Start box.
d. Type 0.04 in the Stop box.
e. Type 0.005 in the Step Size box.
f. Click Add to List.

7  Click OK.
8  Click File>Save to save the model before running the anal-

ysis.

Run the Analysis
To run the analysis:
•    Right-click Analysis in the Project Manager window, and 

select Analyze in the shortcut menu. The time required to 
complete the analysis depends upon the speed and mem-
ory capability of your machine and other applications that 
may be using machine resources. The status of the simula-
tion is reported in the Progress bar.
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6 Post Processing the 
Results
In this chapter you will complete the following tasks:
Plot the magnetic flux density vector.
Plot the current density distribution.
Plot the torque versus time.
Plot the current versus time.
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Plot the Magnetic Flux Density Vector 
Plot the flux density vector on the mid-vertical symmetry 
plane of the device. You previously set up a relative coordi-
nate system (CS1) containing the desired plot plane. 

Create an Object List
Since we want to plot the results only in the two armatures, 
create a list of these two objects to prepare for the plot.
To create the list of objects:
1  Select the Outer_arm and Inner_arm objects.

2  Click Modeler>List>Create>Object List.
The list of selected objects (Objectlist1) is added under 
Lists in the history tree window. 

Plot the Quantity
To create the plot:
1  Change the rendering of both Outer_arm and Inner_arm 

to wireframe by clicking View>Render>Wire Frame.

2  In the history tree, select the RelativeCS1:XY plane under 
Planes.

3  In the project tree, right-click Field Overlays, and select 
Fields>B>B_Vector.
The Create Field Plot dialog box appears.

4  Make sure B_Vector is selected in the Quantity list.
5  Select Objectlist1 in the In Volume list. 
6  Click Done.
7  The B_Vector plot is displayed as shown below. The vector 

values are zero at 0sec as a result of the pulse source used 
in the winding setup having zero initial voltage.
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Set the Solution Context
To change the time step for post processing:
1  Click View>Set Solution Context or double click on the 

time context display in the modeler window.

The Set View Context dialog box appears.
2  Select the Setup1 from the Solution Name pull-down list.
3  Set the time step from the Time pull-down to 0.04s.
4  Click OK. The plot automatically updates to the new time 

as shown.
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Adjust the Plot Parameters
1  Click Maxwell3D>Fields>Modify Plot Attributes.

The Select Plot Folder dialog box appears.

2  Select B from the list, and click OK.
A dialog box appears where you can modify the plot attri-
butes.

3  Click the Scale tab.
4  Select the Use Limits check box.
5  Type 2.0E-006 in the Min box, and type 7.5E-001 in the 

Max box.
6  Click to Plots tab.
7  In the Vector Plot section, set Min to 1 and Max to 5.

Note You may Right-Click in the legend of any displayed plot to 
display a shortcut menu allowing you to hide or modify the 
plot.
6-4 Post Processing the Results 



Getting Started with Maxwell: A Transient Problem
8  Click Apply, and then click Close.
The plot should look similar to the figure below:

9  Right-click on B_Vector1 in the Project Manager window 
and select Plot Visibility in the shortcut menu to turn off 
the plot.

10  Set the Solution Context back to 0s

Plot the Current Density Distribution
To plot the current density distribution on the same XY plane 
of CS1 (RelativeCS1:XY):
1  Select the plane, and right-click in the modeler window.

A shortcut menu appears.
2  Select Fields>J>Mag_J from the shortcut menu. 

The Create Field Plot dialog box appears.
3  Select Outer_arm from the In Volume List. 
4  Click Done to plot. 
5  Set the Solution Context to 0.04s.
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The field partially penetrates the stator, and the transient 
distribution of the current density shows significant skin 
effects. 
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Plot Torque and Current
An important transient analysis feature is the ability to vary 
global quantities as a function of time. Examples of such 
quantities include currents and voltages, power loss, torque/
force, flux linkage of windings, and induced voltages. 

Create a Torque vs. Time Plot
To create a plot of the torque as a function of time: 
1  Right-click Results in the project tree, and select Create 

Transient Report>Rectangular Plot.

The Traces dialog box appears.
2  From the Solution pull-down list, select the solution setup 

(Setup1).
3  From the Category list, select Torque. 
4  Click the New Report button.
5  Click Close to dismiss the dialog. 
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Create a Current vs. Time Plot
To create a plot of the current as a function of time:
1  Right-click Results in the project tree, and select Create 

Transient Report>Rectangular Plot. 

The Traces dialog box appears.
2  From the Solution pull-down list, select the solution setup 

(Setup1).
3  From the Category list, select Winding.
4  From the Quantity list, select Current.
5  Click the New Report button.
6  Click Close to display the dismiss the dialog. 
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Close the Plot
To close the open plot:
•    Click the X in the upper right corner of the plot window.

Note After you close a plot, it is still available to view later, 
listed under Field Overlays in the project tree.
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7 Including Motion in 
the Simulation
In order to include the effects of motion of the Inner_arm 
the object must be isolated from the rest of the model 
using a mesh band. In order to create this mesh band, you 
will add two objects, between the Inner_arm and 
Outer_arm objects.
In general, any moving object must be isolated from the 
stationary model using a mesh band. More information is 
available in the online help under the topic Maxwell 3D 
Technical Notes:Meshing and Band Setting Recommenda-
tions for 3D Transient Applications with Motion. 

 

In this chapter you will complete the following tasks:
Add large motion to the simulation.
Analyze the transient solution with motion.
Post process the transient results.
Close the project and exit Maxwell.
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Add Motion to the Design
Before adding motion to the design, save the “without 
motion” (or non-transient) design and create a copy.
To save and copy the design:
1  Click File>Save to save the design.

2  In the project tree, right-click the Rotational_Act_TR 
design listed under the project, and select Copy.

3  In the project tree, right-click the name of the project 
(also Rotational_Act_TR), and select Paste.
A second copy of the same design appears under the single 
project; by default, the name of the new design is 
Rotational_Act_TR1.

4  Double-click Rotational_Act_TR1 to make it active.

Add a Band Object to the Design
The band object is a regular polyhedron positioned so that it 
contains all rotating objects inside it. 
To add the band object:
1  Set the working coordinate system to CS1: 

Click Modeler>Coordinate System>Set Working CS, 
select RelativeCS1, and click Select.

2  Create a regular polyhedron around the Z axis named 
band:
a. Click Draw>Regular Polyhedron.
b. Type (0, 0 -121) in the (X, Y, Z) boxes, for the origin, and then 

press Enter.
c. Type (52.5, 0, 0) in the (dX, dY, dZ) boxes, for the radius, 

and press Enter.
d. Type (0, 0, 242) in the (dX, dY, dZ) boxes, for the height, and 

press Enter.
The Segment number dialog box appears.

e. Type 24 in the Number of segments text box.
f. Click OK.

The Properties window appears.
g. Click the Attribute tab.
h. Change the Name to band.
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i. Verify that band is assigned the material property of vacuum 
(which should be the default).

j. Click OK.
An polyhedron object named band is drawn.

3  Create a cylinder named air_rotor with the following 
properties
a. Click Draw>Cylinder.

The cursor changes to a small black box, indicating that you are in 
Drawing mode.

b. Enter the center of the cylinder base by typing (0,0,-120) in the 
(X, Y, Z) boxes at the bottom of the screen, and press Enter.

c. Type 51.05 for the radius in the dX box at the bottom of the 
screen, and press Enter.

d. Type 240 for the height in the dZ box, and press Enter.
The Properties window appears.

e. Click the Attribute tab.
f. Change the Name to air_rotor. 
g. Verify that air_rotor is assigned the material property of vac-

uum (which should be the default).
h. Click OK.

A cylinder named air_rotor is drawn.

Assign Motion to the Band Object
The circumference of the band object falls between the inner 
armature and the outer armature and contains inside it the 
air_rotor and Inner_arm objects.
To set the band object:
1  Select band from the history tree.

2  Right-click Model in the project tree under 
Rotational_Act_TR1, and then select Motion 
Setup>Assign Band. 
The Motion Setup dialog box appears.

3  Click the Type tab.
4  Select Rotation as the Motion Type.
5  Set the Rotation Axis to Global:Z and select the negative 

radio button.
6  Click the Mechanical tab.
7  Select the Consider Mechanical Transient check box.
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8  Type 0.0024 in the Moment of Inertia text box and 0.015 
in the Damping text box.

9  Click OK.

Apply Meshing to the Band Object
To apply the appropriate mesh operation to the band object:
1  Select the band object in the history tree.

2  Click Maxwell3D>Mesh Operations>Assign>Inside Selec-
tion>Length Based.
The Element Length Based Refinement dialog box 
appears.

3  Type 20 in the Maximum Length of Elements box, and 
select mm as the units. 

4  Click OK. 
5  To initialize the problem, right-click Setup1 in the project 

tree, and select Revert to Initial Mesh. 
Now you are ready to start the analysis with the effect of 
large motion included.

Set Up the Transient Analysis
To set up a second analysis:
1  Right-click Analysis in the project tree.

A shortcut menu appears.

2  Select Add Solution Setup. 
The Solve Setup dialog box appears.

3  Click the General tab.
4  Type 0.9 in the Stop time box, and select s as the unit.
5  Type 0.005 in the Time step box, and select s as the unit.
6  Add a sweep:

a. Click the Save Fields tab.
b. Select Linear Step from the Type pull-down list to identify the 

type of sweep.
c. Type 0.0 in the Start box.
d. Type 0.9 in the Stop box.
e. Type 0.005 in the Step Size box.
f. Click Add to List.
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7  Click OK.

Run the Transient Analysis
To run the analysis:
•    Under Analysis in the project tree, right-click Setup2, and 

select 
Analyze. 
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Post Process the Transient Results
For the transient case, additional mechanical quantities are 
available (to represent as 2D plots as functions of time), 
which were not available before adding motion to the design. 
When you create a report for a solution that is set to Tran-
sient, these new quantities can be added as traces.

Create a Position vs. Time Plot
To create a plot of the position as a function of time:
1  Right-click Results in the project tree, and select Create 

Transient Report>Rectangular Plot. 

The Traces dialog box appears.
2  From the Solution pull-down list, select the solution setup 

(Setup2).
3  From the Category list, select Position.
4  Click the New Report button.
5  Click Close to dismiss the dialog.
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Current vs. Time Plot with Motion
To create a plot of the current as a function of time:
1  Right-click Results in the project tree, and select Create 

Transient Report>Rectangular Plot. 

The Traces dialog box appears.
2  From the Solution pull-down list, select the solution setup 

(Setup2).
3  From the Category list, select Winding.
4  From the Quantity list, select Current.
5  Click the New Report button.
6  Click Close to dismiss the dialog.
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Torque vs. Time Plot with Motion
To create a plot of the torque as a function of time:
1  Right-click Results in the project tree, and select Create 

Report>Transient>Rectangular Plot. 

The Traces dialog box appears.
2  From the Solution pull-down list, select the solution setup 

(Setup2).
3  From the Category list, select Torque.
4  From the Quantity list, select Moving1.Torque.
5  Click the New Report button.
6  Click Close to dismiss the dialog.
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Create a Power Loss vs. Time Plot
To create a plot of the eddy current power loss in the 
Inner_Arm and Outer_Arm as a function of time:
1  Right-click Results in the project tree, and select Create 

Transient Report>Rectangular Plot. 

The Traces dialog box appears.
2  From the Solution pull-down list, select the solution setup 

(Setup2).
3  From the Category list, select Loss.
4  From the Quantity list, select Solid Loss.
5  Click the New Report button.
6  Click Close to dismiss the dialog.
Including Motion in the Simulation 7-9



Getting Started with Maxwell: A Transient Problem
Close the Project and Exit Maxwell
Congratulations! You have successfully completed his Getting 
Started with Maxwell: Transient Problem! You may close the 
project and exit the Maxwell software.
1  Click File>Save to save the project.

2  Click File>Close.
3  Click File>Exit to exit Maxwell.
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